¿Estas atascado? ¡Yo te ayudo!, pregunta aquí.

Error " Yikes! Invalid device signature " en Arduino Nano

Instrucciones detalladas de los problemas que voy encontrando en mi día a día de aprendizaje con este increible microcontrolador.

Notapor alexiter » Vie Ene 23, 2015 9:37 pm

La cosa comenzo en un pedido grande que hice de arduinos nano (20 unidades), al recibirlos comence a flashearlos para integrarles el Optiboot (un firmware mas rapido, estable y que permite el watchdog en el Arduino Nano, hay un post referente a esto en este mismo foro).

El caso es que de los 20, 3 de ellos no se flasheaban y daban el error " Yikes! Invalid device signature ", tras algo de investigacion por google, y sin encontrar nada claro, intui que el problema deberia de ser de hardware, pero teniendo en cuenta los test que pasan los chips antes de ser ensamblados, deduje que posiblemente fuese un problema de conexion, es decir, algun pin mal soldado.

Y asi fue. Repase las soldaduras de los pines del chip principal (atmel Mega328) y los Nanos se dejaron flashear sin problemas.

En mi caso concreto este era el pin mal soldado:
1.jpg
1.jpg (26.74 KiB) Visto 1835 veces
alexiter
Site Admin
 
Mensajes: 145
Registrado: Dom Nov 17, 2013 9:54 pm

Volver a Arduino

cron
  • Buscar mensajes nuevos
  • Buscar temas sin respuesta
  • ¿Quién está conectado?
  • En total hay 1 Usuario identificado :: 0 registrado, 0 ocultos y 1 invitado (basados en usuarios activos en los últimos 5 minutos)
  • La mayor cantidad de usuarios identificados fue 619 el Dom May 03, 2020 11:11 pm
  • Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado